mardi 27 avril 2010

INE - LAB10 review

3.4 Configure Area 1 without Network Command

Int lo0
ip ospf 1 area 1


3.6 Ospf Authentication

Authentication all area 0 adjacencies without area 0 command :
Don't forget the virtualink authentication

router ospf 1
area 1 virtual-link 150.1.4.4 authentication
area 1 virtual-link 150.1.4.4 authentication-key CISCO


4.2 BGP Summarization

After aggregating all the IGP domain adress space with

aggregate-address 164.1.0.0 255.255.0.0 summary-only

A 164.1.0.0/16 route to Null0 is put on the RIB. As R4 use a default route to join a part of 164.1.0.0 it will use the more specific route to Null0 instead. A way to prevent Null0 from being installed in the RIB is make the distance for the local route 255

router bgp 100
distance 20 200 255


4.3 BGP Default Route

Advertized a BGP default route, only the default, and make it prefered from OSPF default route :

On R1 filter all bgp routes except default

R1
router bgp 300
neighbor 164.1.18.8 default-originate
neighbor 164.1.18.8 prefix-list DEFAULT ou

ip prefix-list DEFAULT seq 5 permit 0.0.0.0/0


On sw2 change the distance for the neighbor lower than distance of ospf 110

Sw2
router bgp 300 distance 100 164.1.18.1 0.0.0.0


4.5 BGP Reachability

During network breakdown, the traffic transit by a non-bgp router causing a routing black hole (non-bgp router doesn't have any bgp route). The idea is then to redistribute bgp onto OSPF. It 's necessary to filter which router redistribute wich AS in

bgp redistribute-internal

Is needed as BGP only redistribute EBGP learned route into IGP by default.


5.4 IGMP Multicast for a group

Prevent a group from being sent to an interface for a given group

int e0/1
ip multicast boundary 1
access-list 1 deny 226.37.1.1
access-list 1 permit any


6.3 RIPng Overs Frame Relay

Don't forget to map pv6 Link Local adress with DLCI for physical or multipoint interface for RIP adjacencies working


7.1 Frame Relay Traffic Shaping

Minimum TC is 10ms.
So for a CIR of 256000 the Bc to configure is 2560
In order packet are fragment to be transmitted in one interval, the size of fragment should be 2560/8 = 320 Bytes

map-class frame-relay DLCI_305
frame-relay cir 256000
frame-relay bc 2560
frame-relay fragment 320

vendredi 23 avril 2010

Ping Macro & Tcl

For IOS, use tcl to script ping

tclsh
foreach address {
164.1.1.1
164.2.2.2
} { ping $address
}


For Catalyst

macro name PINGALL
do ping 164.1.1.1
do ping 164.2.2.2
@
macro global apply PINGALL